Inbound Calling Issue

Incident Report for XTIUM

Resolved

The carrier has resolved the issue and traffic has normalized.
Posted Aug 04, 2025 - 18:10 EDT

Update

XTIUM continues to escalate the issue with the carrier as they work toward service restoration. There is no ETTR at this time.
Posted Aug 04, 2025 - 16:17 EDT

Identified

XTIUM Support has identified an inbound calling issue affecting select customers. The issue has been isolated to an upstream carrier. We are engaging the carrier to identify the root cause of the issue and restore inbound traffic.
Posted Aug 04, 2025 - 14:39 EDT
This incident affected: UCaaS (Telephony).