Intermittent Voice Stability

Incident Report for XTIUM

Resolved

The issue causing intermittent inbound and outbound call failures has been fully resolved and all services are now operating normally. At this time, no further impact is observed.

Thank you for your patience.
Posted Apr 13, 2026 - 17:29 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 13, 2026 - 16:16 EDT

Monitoring

A fix has been implemented, and we are now observing services returning to normal operation.

Our teams are continuing to closely monitor the environment to ensure stability and confirm full resolution. We will provide further updates if any additional issues are identified.

Thank you for your patience.
Posted Apr 13, 2026 - 16:15 EDT

Identified

We are continuing to actively investigate this issue and work toward resolution. The incident has been escalated to our engineering teams and is being treated as a top priority.

Our teams are engaged and progressing through root cause analysis and remediation efforts. We will provide additional updates as more information becomes available.
Posted Apr 13, 2026 - 15:15 EDT

Investigating

XTIUM support is investigating intermittent inbound and outbound call failures,
Posted Apr 13, 2026 - 14:32 EDT
This incident affected: Collaboration (UCaaS).