Intermittent Voice Stability

Incident Report for XTIUM

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 12:30 EDT

Monitoring

Services have normalized for inbound and outbound calling. We are continuing to monitor for any further issues.
Posted Apr 14, 2026 - 11:00 EDT

Identified

The issue has been identified, and we are working toward resolution. Our engineering teams are engaged and progressing through root cause analysis and remediation efforts.
Posted Apr 14, 2026 - 10:06 EDT

Investigating

XTIUM is currently investigating an issue with inbound and outbound call failures,
Posted Apr 14, 2026 - 09:16 EDT
This incident affected: Collaboration (UCaaS).