Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 02, 2026 - 00:00 EDT
Scheduled
Dear Valued Client,
In order to continue to provide worldclass service and customer support, XTIUM will be performing the following maintenance:
Start: 2026-09-02 00:00:00 End: 2026-09-02 03:00:00 Duration: 3 Hours Purpose: We will be performing typical upgrades to the platform load balancers. Impact: Medium Risk. During the upgrade load balancer pairs are failed over. This may typically result in a single dropped packet, most services are not impacted by this process. Required user actions: No customer impact is expected. If any underlying services rely on session authentication you may need to refresh your session by logging off and back on to the impacted service.
If you have an urgent incident, please call the XTIUM Help Center at 888.779.8486. Thank you for your attention and understanding.
Posted Aug 18, 2026 - 11:09 EDT
This scheduled maintenance affected: Cloud (Data Center Core Services) and Cloud.