Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2026 - 09:21 EDT
Scheduled
Dear Valued Client,
In order to continue to provide worldclass service and customer support, XTIUM will be performing the following maintenance:
Start: 2026-05-23 13:00:00 End: 2026-05-23 16:00:00 Duration: 3 Hours Purpose: Cisco Umbrella Portal Vendor Maintenance – XTIUM Tenant Consolidation Impact: Minimal risk is expected. This is a vendor-managed maintenance event with no anticipated impact to production Umbrella security services. Administrative portal access may be intermittently unavailable. Required user actions: No customer action is required. Customers may wish to avoid making administrative changes in the Umbrella portal during the maintenance window.
If you have an urgent incident, please call the XTIUM Help Center at 888.779.8486. Thank you for your attention and understanding.
Posted May 08, 2026 - 11:36 EDT
This scheduled maintenance affected: Security (Cisco Web Security (third-party)) and Security.